incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 119090] Default Encryption Fails for Down-Level Implementations
Date Tue, 20 Mar 2012 01:39:56 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119090

orcmid <orcmid@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #77345|                            |review?
              Flags|                            |

--- Comment #12 from orcmid <orcmid@apache.org> 2012-03-20 01:39:56 UTC ---
Created attachment 77345
  --> https://issues.apache.org/ooo/attachment.cgi?id=77345
Change saveopt.cxx so that both UseSHA1InODF2 and UseBlowfishInODF2 are true by
default

This issue is resolved by making the default configuration settings for
UseSHA1InODF2 and UseBlowfishInODF2 to true.  This will provide full
interoperability by defautl.

Users who prefer to use AES256-cbc encryption and are not concerned about
down-level interoperability can explicitly set the flags to false in their
configuration.

Note 1: Documents that are encrypted by AES256 will still be accepted, they
just won't be produced by default.

Note 2: There may need to be additional changes to ensure that the produced
package manifest reverts to default values in this case, rather than providing
explicit attributes that are not recognized by down-level implementations. 
That can be checked once this change is in place.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message