incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 119086] New: Write-protected document cannot be modified by API
Date Sun, 18 Mar 2012 08:49:44 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119086

             Bug #: 119086
        Issue Type: DEFECT
           Summary: Write-protected document cannot be modified by API
    Classification: Code
           Product: api
           Version: OOo 3.3
          Platform: All
        OS/Version: All
            Status: CONFIRMED
          Severity: normal
          Priority: P3
         Component: code
        AssignedTo: ooo-issues@incubator.apache.org
        ReportedBy: marcelly@club-internet.fr


Since OpenOffice.org version 3.3 it is possible to have a password protecting a
Calc or Writer document from modifications. Such document can be read, not
modified.
See
http://www.openoffice.org/dev_docs/features/3.3/#Increased_Document_Protection_in_Writer_and_Calc

The API aspect has been forgotten in the development. The consequence is that
such documents cannot be created or modified by program.

It should be possible, by API :
- to create a document and save it with a password for write-protection
- to open a write-protected document, modify it if the password is provided,
and save it keeping the write-protection.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message