incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 119076] New: Japanese texts do not hold font settings on save and reload after "Default Formatting" is applied
Date Fri, 16 Mar 2012 05:13:14 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119076

             Bug #: 119076
        Issue Type: DEFECT
           Summary: Japanese texts do not hold font settings on save and
                    reload after "Default Formatting" is applied
    Classification: Application
           Product: Word processor
           Version: OOo 3.3
          Platform: PC
        OS/Version: Windows, all
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: formatting
        AssignedTo: ooo-issues@incubator.apache.org
        ReportedBy: ahiroshige@ashisuto.co.jp


Newly entered(or pasted) Japanese texts do not hold its font settings on
save and reload after "Default Formatting" had been applied.

Steps to reproduce:
1. Start new Writer document
2. Change font size and enter some Japanese texts
3. Select the Japanese texts and go to Format -> Default Formatting
4. Select the Japanese texts and change font size
5. Save and close file
6. Open the file to see the font setting goes back to that of the
   Default Formatting

The steps I described above is just to reproduce the bug on new doc.
I know the 2nd step doesn't really make sense in real life, but this bug
first started off from a file that had some data copied into it from another
file which had its own format settings.

So the Default Formatting function was used to reset all the indents and line
spacing at once, and then re-applied the font size to suite the current file.

And as far as my testing goes, it only happens when I do the above to Japanese
texts (Or say, double bite letters perhaps?)

Also, the bug doesn't occur if the same process is applied to existing letters.
It only happens to texts newly entered, or pasted.

Here are the work arounds I found so far:
* Apply Default Formatting, Save, File -> Reload, and then change font settings
* Apply Default Formatting, change font settings, select texts, cut and paste

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message