incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 119009] Primary Index cannot be created
Date Sat, 03 Mar 2012 13:58:14 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119009

r4zoli <r4zoli@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |r4zoli@apache.org

--- Comment #1 from r4zoli <r4zoli@apache.org> 2012-03-03 13:58:14 UTC ---
All tables needs primary key in Base to add data.

The copy table wizard contains option in first window when you can select it
and it add PK with new ID column. If you miss that step, the copy wizard warns
you to add PK to your table. If you ignore that warning, the wizard create
table without PK. This is a known bug, I needs to find that, and mark this as
duplicate of that bug.

But you can use with menu Tools>SQL...   SQL command window, and execute this
commmand: 

ALTER TABLE "Tabelle1" ADD  "ID"  INTEGER GENERATED BY DEFAULT AS IDENTITY
BEFORE "a".  
If it is run successfully, add new "ID" field with autoincrement values. After
that refresh table, View>Refresh Table... then you can add more data to your
table

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message