incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 119004] Cannot install on clean Windows XP SP3
Date Fri, 02 Mar 2012 18:34:36 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119004

--- Comment #7 from Hans Zybura <hzybura@zybura.com> 2012-03-02 18:34:36 UTC ---
By now I have tested installing /DevSnapshots-Rev.1293550/win32/OOo_3.4.0_Win_x
86_install_en-US.exe and /DevSnapshots-Rev.1293550/win32/OOo_Dev_3.4.0_Win_x
86_install_en-US.exe on 5 different Windows XP virtual machines, all with the
same result: 

"Error: An error occurred during registration of extensions!"

All vm's are clean in the sense that they never had an installation of an
earlier version of OOo or LibreOffice. Otherwise, they differ in "cleanliness".

1. XP 32-Bit SP3 English, security upd., old, MS Office 2000 and 2003, vm
hosted with Virtual PC 2007 on a very fast Windows 7 64-Bit system

2. XP 32-Bit SP3 German, fresh, security upd., Firefox, both before installing
.Net 2.0 and after, vm hosted with Virtual PC 2007 on a very fast Windows 7
64-Bit system

3. another XP 32-Bit SP3 German, fresh, security upd., both before and after
installing
- .Net 4.0 (repeated testing)
- Java Runtime Environment (repeated testing)
- Windows 7.3 SDK (repeated testing)
This vm is hosted with Virtual Box on a very fast Windows 7 64-Bit system

4. XP 32-Bit SP2 German, old, used for testing VBA-AddIns on MS Word 2000, vm
hosted with Virtual PC 2007 on an old, slow Win XP SP3 host system.

5. A different XP 32-Bit SP3 German, old, used for testing VBA-AddIns on MS
Word 2002, vm hosted with Virtual PC 2007 on an old, slow Win XP SP3 host
system. Main difference ist formatting of virtual hard disk: FAT32 here

More testing:
On VM No. 1 I installed OOo 3.3. No problem. Then installed AOO 3.4. over it.
No problem, everything is fine. Then uninstalled AOO 3.4 again, uninstalled
Microsoft Visual C++ 2008 Redistributable (installed by OOo 3.3!!), uninstalled
JRE, and cleaned the file system: deleted folders OpenOffice.org in user
profile AND in Program Files, in Windows Registry I used search term
"OpenOffice" -> deleted every appearance. That's all, not that bad.

Then tried to install AOO 3.4 again. Result:

"Error: An error occurred during registration of extensions!"

Means: 1) I could clean a tainted (but not heavily loaded with other programs)
test system easily to the point from where I could invoke the same error as
before. 2) Next candidates for testing are absence/presence of Microsoft Visual
C++ 2008 Redistributable (from the OOo 3.3 package) and OpenOffice 3 folder in 
Program Files.

If this isn't confirmation enough, I don't know the meaning of it.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message