incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118999] Leap year not correctly calculated
Date Sat, 03 Mar 2012 21:53:31 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118999

orcmid <orcmid@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |orcmid@apache.org

--- Comment #5 from orcmid <orcmid@apache.org> 2012-03-03 21:53:31 UTC ---
I have tested for the reported defect using a simple ODF Spreadsheet document. 
All tests are with Microsoft Windows distributions of OOo-lineage binaries.

The document was created with Apache OOO-dev 3.4 Developer Preview r1293550. 
This document shows correct handling of 2000-02-29 (and 2400-02-29) and correct
treatment of some intermediate leap-year dates and their adjacent dates.  It
was saved successfully.  This document was then loaded in different product
installs as follows:

FOR NO VERSION OF OpenOffice.org, does the defect occur.  I verified this by
loading the created document in
  OpenOffice.org 2.4.1
  OpenOffice.org 3.2.0
  OpenOffice.org 3.3.0
  OOo-dev 3.4.0 Oracle Build 9586
  OOo-dev 3.4.0 AOO Developer Preview r1293550
The defect simply does not appear.

FOR LIBREOFFICE, THE EXPERIENCE IS DIFFERENT
  LibreOffice 3.3.2 does not exhibit the defect
  LibreOffice 3.5.0 does exhibit the defect

My preliminary conclusion is that this defect is not inherited from
OpenOffice.org releases nor is it present in the Apache OpenOffice code (at
least for Windows).  It appears that the problem is unique to LibreOffice on a
path beyond when the code base was forked from OpenOffice.org.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message