incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118894] New: Create table failed use wizard if we change some value in setting
Date Fri, 10 Feb 2012 02:52:30 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118894

             Bug #: 118894
        Issue Type: DEFECT
           Summary: Create table failed use wizard if we change some value
                    in setting
    Classification: Application
           Product: Database access
           Version: OOo 3.4 Beta
          Platform: PC
        OS/Version: Windows 7
            Status: CONFIRMED
          Severity: normal
          Priority: P3
         Component: SRB
        AssignedTo: dbaneedsconfirm@openoffice.org
        ReportedBy: polo8495@hotmail.com
                CC: ooo-issues@incubator.apache.org


If we create table use wizard, in the wizard we change some value to invalid,
then change them back to correct one, it will failed due to the invalid value

Step:
1. Create a DB
2. Click "Use Wizard to Create Table" to create table
3. Select Personal and add sample tables "Accounts" all fields then next
4. in AutoValue dropdown list select "Yes", and set Auto-Increment statement to
value "1". Click next
5 Select "Use an existing field as primary key" select "AccountID" as
Fieldname, and check the Auto value. 
6. Goback to step 4 change the value to default on.
7. Click next, next,finish

Result:
A unexpect error display 
SQL Status: 37000
Error code: -11

Unexpected token: 1 in statement [CREATE TABLE "Accounts" ("AccountID" INTEGER
NOT NULL 1]

If we close this Wizard and redo all steps except step 4 and step 6, it wil
create the tab successfully

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message