incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 115092] Dotted transparent lines disappear in edit mode
Date Tue, 07 Feb 2012 09:34:42 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=115092

Armin Le Grand <Armin.Le.Grand@me.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|CONFIRMED                   |ACCEPTED

--- Comment #4 from Armin Le Grand <Armin.Le.Grand@me.com> 2012-02-07 09:34:42 UTC ---
ALG: This has nothing to do with the number of points that can be rendered
(BTW: Metafile is limited to 65535 while primitives use 2^32). It is an error
in an optimization which was done exactly for big charts like this. The fat
line drawing checks for actual linewidth and does some extras for > 1 to 3 to
not paint fat line geometry. Above that the primitive decomposition is used.
There is also a fallback when more than 1000 points are used to use the old VCL
painter for resource reasons to not create all those decompositions and for
speed reasons. There, a bool to check if this was done was used wrong /leading
to the symptom that only the 1st segment of a dashed line is drawn).

ALG: This is an error which needs fixing, did so and checking functionality...

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message