incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 114997] 'Regular' apostrophe not found
Date Fri, 24 Feb 2012 04:56:46 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=114997

Mark Vasko <mwvasko@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mwvasko@gmail.com

--- Comment #3 from Mark Vasko <mwvasko@gmail.com> 2012-02-24 04:56:46 UTC ---
I tested this in the following configurations

OOo 3.3.0 (build 9567) on win 7 
OOo 3.4.0 (build 9582) on win 7 

I duplicated the problem with the file attached by the original reporter.

I also created my own file with bold and italicized apostrophes and then use
the find function. I was able to see some interesting behaviors based on what I
selected in the format box for the text type. I haved attached that file to the
report.

Here are my steps:
1 Open the file
2 hit Ctrl + F to open the find dialogue window
3 Enter ' in the Search for text field
4 click find

This iterated through successfully.

Next I did the following

1 Click on more options -> format
2 Click on "Regular" under the typeface options then click ok
3 Click on find

When I selected the "Regular" option under Typeface, the first nine apostrophes
were skipped, 3 of which were regular. The find option then skips the last two
apostrophes as well, which are also in a regular format but were several lines
below the first line. The find went back up to where it had identified what it
thought was the first regular apostrophe, again skipping the first nine
apostrophes when it wraps around.

I tested with using the letter 's' in the same fashion and this appears to be
not just limited to apostrophes because I was able to observe the same behavior
by repeating the same steps.

I went back into the Format and instead selected "Italics" Typeface option
instead. This time, the search correctly identifies the first italicized and
then also the following two italicized apostrophes immediately after it. When I
hit find again, it skipped the next three apostrophes and went to the first
regular apostrophe that is down a few lines.

I went back into the format dialogue and clicked reset to reset the formatting
settings however I noticed that the Typeface was set to regular. When I tried
the search, the search wasn't corrected and was still skipping characters. I
cleared the Typeface text box and clicked ok, and tried the find option which
still was skipping characters. I went back into the format dialogue box, and
the word Regular was back in the Typeface text box. So the setting seems to be
held there.

At this point, I noticed that there were parameters listed under the search for
text box. So I closed out of the program, saving my file and then opened the
file back up. I also noticed that under the Search for text box at this point,
the parameters stated "Not italic, normal" and from what I can tell the
parameters based on what is being fed from the format box are Not Italic/Italic
and Normal/Bold 

I tried putting a letter before and after the first apostrophe in the file, in
case it was looking for characters around the apostrophe for some reason, but
that didn't change the behavior of the find function. It still passed up
characters that met the parameters.

This also impacts the replace feature, since the ability to find the character
is hampered. This may more significant because users may rely on the replace
feature thinking that the system made the correct changes when it may have
troulbe finding the characters to replace.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message