incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 65372] Protected macro: Unicode string would be destroyed when a macro be protected by password.
Date Thu, 19 Jan 2012 09:30:45 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=65372

--- Comment #13 from hanya <hanya.runo@gmail.com> 2012-01-19 09:30:45 UTC ---
Created attachment 77149
  --> https://issues.apache.org/ooo/attachment.cgi?id=77149
Patch to change encoding to UTF-8 in code.bin file

This patch change to use fixed encoding UTF-8 as save encoding and loading is
done by UTF-8 encoding when the encoding flag is UTF-8 in code.bin file.
Therefore code.bin file created by current build should be opened correctly.

But the multi-byte strings stored in code.bin which created by the current
build are shown like "????". They are failed to encode to output encoding and
converted to strings with "?" character. The code.bin file created by current
build keeps broken strings in executable files by users without password input,
which needs re-save with patched build to store correct strings into code.bin
file.

Non-ASCII characters would be incompatible with this patch. If there is a way
to check the encoding to the specific encoding is finished without any error,
it could be keep compatibility on the code.bin encoded with non-ascii encoding.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message