incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118839] New: NPAPI browser plugin incorrectly registers itself in the registry
Date Thu, 26 Jan 2012 16:26:52 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118839

             Bug #: 118839
        Issue Type: DEFECT
           Summary: NPAPI browser plugin incorrectly registers itself in
                    the registry
    Classification: Code
           Product: framework
           Version: OOo 3.3
          Platform: PC
        OS/Version: Windows 7
            Status: UNCONFIRMED
          Severity: normal
          Priority: P5
         Component: code
        AssignedTo: tm@openoffice.org
        ReportedBy: rchl2k@gmail.com
                CC: ooo-issues@incubator.apache.org


Mozilla plugin is registered in registry this way:

HKEY_CURRENT_USER\Software\MozillaPlugins\@sun.com/npsopluginmi;version=1.0 
 Path=C:\Program Files (x86)\OpenOffice.org 3\program

The problem is that "Path" points to a directory rather then the plugin itself
(np*.dll).

Only Firefox seems to be able to handle that, neither Opera nor Chrome can find
the plugin.

Even Mozilla documentation suggests that it should be a path to the plugin file
-
https://developer.mozilla.org/En/Plugins:_The_first_install_problem#Windows_Installation_Using_the_Registry

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message