incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118821] DevSnapshots-Rev.1231878 - component manager not available
Date Mon, 23 Jan 2012 11:30:16 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118821

brinzing <brinzing@openoffice.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|CLOSED                      |UNCONFIRMED
                 CC|                            |brinzing@openoffice.org
         Resolution|INVALID                     |

--- Comment #4 from brinzing <brinzing@openoffice.org> 2012-01-23 11:30:16 UTC ---
Hi Oliver

the issue is that the "oleautobridge.uno.dll" is *missing*
in the installation set. Adding "oleautobridge.uno.dll" 
and registering it solves the problem.

imho this has nothing todo with windows registry system integration.
please add "oleautobridge.uno.dll" and registration into dev builds.

this is what i did:

- copy "oleautobridge.uno.dll" to $BRAND_BASE_DIR/program
  (taken from rev 1230786)

- insert into $BRAND_BASE_DIR/Basis/programm/services.rdb:

<component loader="com.sun.star.loader.SharedLibrary"
 uri="vnd.sun.star.expand:$BRAND_BASE_DIR/program/oleautobridge.uno.dll">
 <implementation name="com.sun.star.comp.ole.OleClient">
  <service name="com.sun.star.bridge.OleObjectFactory"/>
  <service name="com.sun.star.bridge.oleautomation.Factory"/>
 </implementation>
 <implementation name="com.sun.star.comp.ole.OleConverter2">
  <service name="com.sun.star.bridge.OleBridgeSupplier2"/>
  <service name="com.sun.star.bridge.oleautomation.BridgeSupplier"/>
 </implementation>
 <implementation name="com.sun.star.comp.ole.OleConverterVar1">
  <service name="com.sun.star.bridge.OleBridgeSupplierVar1"/>
 </implementation>
 <implementation name="com.sun.star.comp.ole.OleServer">
  <service name="com.sun.star.bridge.OleApplicationRegistration"/>
  <service name="com.sun.star.bridge.oleautomation.ApplicationRegistration"/>
 </implementation>
</component>

- open aoo and check with macro:

  OPTION EXPLICIT
  Sub Test
    Dim oManager as Object
    oManager = CreateObject("com.sun.star.ServiceManager")
    MsgBox isNull(oManager)
  End Sub

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message