incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118814] New: Over-long timeout can make XMailServer appear to hang OOo
Date Wed, 18 Jan 2012 16:10:38 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118814

             Bug #: 118814
        Issue Type: DEFECT
           Summary: Over-long timeout can make XMailServer appear to hang
                    OOo
    Classification: Code
           Product: api
           Version: OOo 3.3
          Platform: PC
        OS/Version: Windows XP
            Status: UNCONFIRMED
          Severity: minor
          Priority: P5
         Component: code
        AssignedTo: tbo@openoffice.org
        ReportedBy: donjaime@freenet.de
                CC: ooo-issues@incubator.apache.org


Created attachment 77146
  --> https://issues.apache.org/ooo/attachment.cgi?id=77146
Contains a macro that attempts to connect to a mail server on the wrong port

When trying to connect to an unresponsive mail server, or when trying to
connect to the wrong port, XMailServer can take an overly long time to time out
and throw an error, giving the impression that OOo has hanged.

The time that elapses before the error appears seems to depend on the server
address, unless that's just coincidence. The address used in the sample file is
the one that took the longest (several minutes). (The port number used is a
typo of my mail client's settings.)

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message