incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118791] New: XMailMessage attachment unusable if file name (ReadableName) contains non-ASCII characters
Date Mon, 16 Jan 2012 07:32:13 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118791

             Bug #: 118791
        Issue Type: DEFECT
           Summary: XMailMessage attachment unusable if file name
                    (ReadableName) contains non-ASCII characters
    Classification: Code
           Product: api
           Version: version58
          Platform: PC
        OS/Version: Windows XP
            Status: UNCONFIRMED
          Severity: enhancement
          Priority: P5
         Component: definition
        AssignedTo: tbo@openoffice.org
        ReportedBy: donjaime@freenet.de
                CC: ooo-issues@incubator.apache.org


Created attachment 77134
  --> https://issues.apache.org/ooo/attachment.cgi?id=77134
Test file sends two messages, one with attachment "Confirmation", one with
attachment "Best├Ątigung"

If XMailServer is used to send an XMailMessage with an attachment whose
ReadableName contains non-ASCII character, the attachment header is garbled and
the attachment cannot be extracted. For example: if the attachment name is
"Best├Ątigung", the Content-Disposition header is rendered as:

Content-Disposition: =?utf-8?q?attachment=3B_filename=3D=22Best=C3=A4tigung?=
    =?utf-8?q?=22?=

while with file name "Confirmation", the header is:

Content-Disposition: attachment; filename="Confirmation"

Presumably the problem is something simple like "encode(foo & bar)" instead of
"foo & encode(bar)"

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Mime
View raw message