incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118791] XMailMessage attachment unusable if file name (ReadableName) contains non-ASCII characters
Date Tue, 17 Jan 2012 02:36:07 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118791

--- Comment #6 from Ariel Constenla-Haile <arielch@apache.org> 2012-01-17 02:36:07 UTC
---
(In reply to comment #4)
> Replaced as instructed. I had to edit line 46 to dbg = False because the ascii
> codec was choking on line 128, and when that was fixed I got:
> 
> An exception occurred 
> Type: com.sun.star.uno.RuntimeException
> Message: <type 'exceptions.RuntimeError'>: No SSL support included in this
> Python, traceback follows
>   C:\Program Files\OpenOffice.org
> 3\Basis\program\python-core-2.6.1\lib\smtplib.py:615 in function starttls()
> [raise RuntimeError("No SSL support included in this Python")]
>   C:\Program Files\OpenOffice.org 3\Basis\program\mailmerge.py:88 in function
> connect() [self.server.starttls()]
> .
> 
> So I used ConnectionType Insecure and then it worked.

yes, this was bug 118787 that made you use insecure connection when specifying
"SSL". It compared"Ssl" != "SSL" in a case sensitive way; as these string are
not equal, it used an insecure connection.

This seem to have worked for you (your smtp server seems to use insecure
connection), but didn't work with Gmail's smtp server for example.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message