incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118736] XMailMessage methods fail in BASIC
Date Sat, 07 Jan 2012 17:39:26 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118736

Ariel Constenla-Haile <arielch@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |arielch@apache.org

--- Comment #1 from Ariel Constenla-Haile <arielch@apache.org> 2012-01-07 17:39:26 UTC
---
(In reply to comment #0)
> With the fix to bug 111508 it is now possible using Basic to create an email
> message with a body and an attachment and send it using the XMailServer
> interface. (Sample code at
> www.oooforum.org/forum/viewtopic.phtml?p=462063#462063)
> 
> For this to work the python-UNO bridge has to be installed, which should not be
> necessary for Basic scripting.

the UNO component is implemented in Python, so you need Python and PyUNO (both
installed by default in vanilla OpenOffice.org).

> More seriously, the mail message created by com.sun.star.mail.MailMessage does
> not support the documented methods of the XMailMessage interface to add
> recipients and attachments: if they are used an error is thrown when an attempt
> is made to send the message.

can you attach a test document with a sample macro?

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message