incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118723] New: ICU regexp replace: reference of group like $1 in replace text, is always empty
Date Wed, 04 Jan 2012 10:23:22 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118723

             Bug #: 118723
        Issue Type: DEFECT
           Summary: ICU regexp replace: reference of group like $1 in
                    replace text, is always empty
    Classification: Application
           Product: Word processor
           Version: OOo 3.4 Beta
          Platform: PC
        OS/Version: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: P5
         Component: code
        AssignedTo: writerneedsconfirm@openoffice.org
        ReportedBy: hanya.runo@gmail.com
                CC: ooo-issues@incubator.apache.org


Reference a group like $1 in replace text do not work anymore with the regexp
engine replaced with ICU's one.

Here is an example to reproduce: 
Text: ab
Search for: a(b)
Replace with: $1

Results empty string, it should be "b". This works on OOo 3.3.0.
The history of the modification in Undo button shows "Replace: 'ab' -> ''"
means 
$1 is empty. When I change the replace text to $0, it worked.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message