incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118720] dmake openofficedev is broken
Date Tue, 03 Jan 2012 14:19:23 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118720

--- Comment #2 from Ariel Constenla-Haile <arielch@apache.org> 2012-01-03 14:19:23 UTC
---
put_childprojects_into_installset
(/solenv/bin/modules/installer/epmfile.pm#3047) is invoked on
solenv/bin/make_installer.pl if the following condition is true:

if ($installer::globals::addchildprojects) {
installer::epmfile::put_childprojects_into_installset($installer::globals::epmoutpath,
$allvariableshashref, $modulesinproductarrayref, $includepatharrayref); }

(solenv/bin/make_installer.pl#1754)


$installer::globals::addchildprojects is set to 1 under the following
condition:

if (( $allvariables->{'JAVAPRODUCT'} ) ||
    ( $allvariables->{'ADAPRODUCT'} ) ||
    ( $allvariables->{'UREPRODUCT'} ) ||
    ( $allvariables->{'ADDREQUIREDPACKAGES'} )) {
$installer::globals::addchildprojects = 1; }

(solenv/bin/modules/installer/control.pm#709)


In this case, instsetoo_native/util/openoffice.lst#224
JAVAPRODUCT is set to 1 for OpenOffice_Dev

Change JAVAPRODUCT to 0
Change script from setup_osljre to setup_osl

Developer Snapshot do not install a JRE.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message