incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118697] New: Impossible to reset a tab color to Default by API
Date Mon, 26 Dec 2011 18:06:37 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118697

             Bug #: 118697
        Issue Type: DEFECT
           Summary: Impossible to reset a tab color to Default by API
    Classification: Code
           Product: api
           Version: OOo 3.3
          Platform: PC
        OS/Version: Windows XP
            Status: UNCONFIRMED
          Severity: normal
          Priority: P5
         Component: code
        AssignedTo: tbo@openoffice.org
        ReportedBy: marcelly@club-internet.fr
                CC: ooo-issues@incubator.apache.org


The default color of a sheet tab is -1.
However, when setting -1 to TabColor by API, the value remains unchanged.

Set tab of Sheet 1 to a particular color, e.g. Blue. Then run this macro:

Sub Main
Dim sh As Object
sh = ThisComponent.Sheets(0)
MsgBox("Before :" & sh.TabColor)
sh.TabColor = -1
MsgBox("After :" & sh.TabColor)
End Sub

There is a nasty work-around : set to color -2 (or any other negative value)
This value is accepted and the tab displays as default. But this is not a
normal value.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message