incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118638] New: Query with left or right join fails in 3.3 but worked in 3.2
Date Thu, 24 Nov 2011 18:55:39 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118638

             Bug #: 118638
        Issue Type: DEFECT
           Summary: Query with left or right join fails in 3.3 but worked
                    in 3.2
    Classification: Application
           Product: Database access
           Version: OOo 3.3
          Platform: PC
        OS/Version: Windows Vista
            Status: UNCONFIRMED
          Severity: normal
          Priority: P5
         Component: none
        AssignedTo: dbaneedsconfirm@openoffice.org
        ReportedBy: bill@dornbush.net
                CC: ooo-issues@incubator.apache.org


I upgraded to 3.3 from 3.2.  I ran a database report based on a query which
returned no data but worked fine in 3.2.
The query is:
SELECT "Laptop"."Laptop", "Laptop"."CPCN", "Counselor"."Lname" FROM { OJ
"Counselor" AS "Counselor" RIGHT OUTER JOIN "Laptop" AS "Laptop" ON
"Counselor"."Laptop" = "Laptop"."Laptop" }

If the right outer join is removed, then the query runs but of course returns
only data where both tables contain "laptop"

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message