incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 118623] Update Rhino from 1.5R5 to 1.7R3
Date Thu, 24 Nov 2011 17:11:18 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118623

--- Comment #4 from hanya <hanya.runo@gmail.com> 2011-11-24 17:11:18 UTC ---
@Pedro
> - FreeBSD uses this patch which will likely be relevant
Now AOO needs Java 5 or 6 and it has w3c dom. If it is there, rhino use it and
xmlbeans is not needed.
https://developer.mozilla.org/en/New_in_Rhino_1.7R1#section_3
> - There is a new file under the LGPL in your first patch
I have mentioned about it in the comment. I have not noticed license header of
most files are updated to AL2 until today. The license header is copyrighted to
Oracle and maybe it is included in SGA. But I could not replace it myself.
> - We still cant carry rhino in our distribution, and downloading + patching
is not acceptable either.
Oh, it seems I confused on it.
> or try Chrome V8
I have tried to make V8-UNO bridge but I have met a problem on exceptions
between V8 and UNO. And I also considered about to use V8 as macro engine.
Python has some useful modules and easy to import to use with Python macros.
But V8 does not have import feature except for the proposed by CommonJS
modules. Java's components can not be used on V8 too. If V8 is introduced as a
macro engine, it takes a position below the Basic.

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message