incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: Dmake binaries ?
Date Sun, 21 Oct 2012 02:42:30 GMT
On Sat, Oct 20, 2012 at 10:10 PM, Pedro Giffuni <pfg@apache.org> wrote:
>
>
> --- Sab 20/10/12, Rob Weir <robweir@apache.org> ha scritto:
>
>>
>> Pedro Giffuni wrote:
>> > Hi Rob;
>> >
>> > The binary was something I built on my spare time with
>> MSVC 9.0 never used.
>> > I got a report that the windows executable doesn't work
>> and that it doesn't build with MSVC 2010.
>> >
>>
>> Which issue is it?  I don't see one that matches this
>> description here:
>>
>> http://code.google.com/a/apache-extras.org/p/dmake/issues/list
>>
> It was reported by direct email. I "solved" it by removing the previous windows binary.
>

Since your original note says you are no longer interested in
maintaining Dmake it would be good if you could either add this defect
report or ask the reporter of the issue to add it.

And you solved absolutely nothing by deprecating the Windows binary
that is needed for building AOO 3.4.1, especially when you notice that
it has been downloaded 1000 times.   I fail to see your logic in this.

>> > I deprecated the windows binary package: apparently
>> there is demand as there were around 1000
>> > downloads.
>> >
>> >
>> > Dmake is in need of real love. More documentation is
>> welcome but the main problem is that I just don't care about
>> it.
>> >
>>
>> According to the change log. nothing has changed in Dmake
>> since
>> February:  http://code.google.com/a/apache-extras.org/p/dmake/source/list
>>
>> What are we using for Windows release builds of 3.4.0 and
>> 3.4.1?
>> Surely there was something that worked?  And if the
>> code hasn't
>> changed since February, then why is there a problem now.
>>
>
> I use 4.12.2 regularly. AOO uses 4.12.
>
>> I'm obviously missing something.
>>
>
> This is not a problem for OpenOffice since we build from source but people would like
to have a binary version. I wont be providing any unless someone contributes it.
>

Didn't you just say that it no longer builds from source?

I'm not asking you to do any hard, Pedro.  Just don't delete the stuff
that works and which is dependency for AOO 3.4.1.

Put your axe away.

-Rob

>
> Pedro.

Mime
View raw message