incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jan iversen <jancasacon...@gmail.com>
Subject Re: svn update, simple question.
Date Thu, 25 Oct 2012 12:02:47 GMT
On 25 October 2012 13:03, Herbert Duerr <hdu@apache.org> wrote:

> Hi Jan,
>
>
> On 25.10.2012 11:09, jan iversen wrote:
>
>> Now I know what I did wrong, I did run configure again but not in a new
>> shell (forgot the environment variables).
>>
>
> Good. Do you happen to know which environment variables were the problem
> in this case? It would be great to have a mechanism that avoided this
> source of confusion but cleaning up such environment variables. AFAIK most
> of them are supposed to be unset in the script written by the bootstrap
> step.

Yes at least I know one "CC", I had for experimental use changed it to a
different compiler, and configure used it for the Linux script.

I will check next time to see if there are others.



>
>
>  I think the real hazzle is to understand the process, once you get the
>> initial build done and understand a bit about the build/makefiles it is
>> pretty clean.
>>
>> I worked in another project, where the build required you to open 3
>> shells,
>> and start different commands at different stages, that was challenging
>> compared to this :-)
>>
>
> Wow, that tops the complexity of the AOO build experience quite a bit. For
> an open-source project I'm afraid we're still way too challenging,
> especially since the project was disrupted in the transition from the
> classic OOo build system to a gnumake based system.
>
> Herbert
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message