incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reizinger Zoltán <zreizin...@hdsnet.hu>
Subject Report builder (was:Re: [EXT] MySQL SDBC Connector)
Date Fri, 12 Oct 2012 14:39:41 GMT
2012.10.12. 16:29 keltezéssel, Ariel Constenla-Haile írta:
> Hi Zlotan,
>
> On Fri, Oct 12, 2012 at 04:17:46PM +0200, Reizinger Zoltán wrote:
>> 2012.10.12. 15:21 keltezéssel, Ariel Constenla-Haile írta:
>>> On Thu, Sep 06, 2012 at 10:50:21PM -0300, Ariel Constenla-Haile wrote:
>>>> Hi *,
>>>>
>>>> I managed to build the MySQL Connector extension and make it work on
>>>>
>>>> * CentOS 5.8 32 and 64 bits
>>>> * Ubuntu 10.04 LTS 32 and 64 bits
>>>> * Fedora 15 32 bits and 17 64 bits
>>>> * Windows XP 32 bits
>>>> * Windows 7 64 bits (arch. does not matter on Win, AOO is a 32 bits
>>>>    application)
>>>>
>>>> You can find the extension binaries on
>>>> http://people.apache.org/~arielch/extensions/aoo-my-sdbc/
>>>>
>>>> These are supposed to be "universal" builds, that is, run on every
>>>> Windows version, and Linux distro (Linux base is CentOS 5 with glibc
>>>> 2.5). Everyone is welcome to test if they work on their systems; by
>>>> "work" I mean it does not crash, I didn't fix any of the existing
>>>> issues, it was just a try-to-build-it (for now).
>>> I also managed to build the Report Builder:
>>> http://people.apache.org/~arielch/extensions/ReportBuilder.oxt
>> It is Good news :)
>> You plan to work on bug fixes in report builder?
> I'm not sure yet, because studying/debugging the Java stuff may not be
> that fun; on the other hand, working on the MySQL and the PostgreSQL
> drivers has been really nice :) (I had to study-by-debugging the
> MySQL/Connector C++, Connector C, and even parts of glibc to find out
> why localhost connections didn't work on Linux).
>
> The Report Builder, in its current state, seems to work fine on Windows,
> on Linux I see mixing results, depending on the distro.
Unser windows I tested works in most cases.
Only thing which not works, the charts, if you open report with chart 
included it is fails with error:
"Failed to parse the report" - possibly caused by changes in Chart, 
which not followed in report buider.
I could sen my test database with chart in reports, to see that.
Best regards,
Zoltan
>
>
> Regards


Mime
View raw message