incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [RELEASE]: new snapshot base don revision r1400866
Date Fri, 26 Oct 2012 19:16:48 GMT

Hi Ricardo,

On Fri, Oct 26, 2012 at 08:24:26PM +0200, RGB ES wrote:
> On the forums we are testing the ES version and I have a doubt about non
> translated text on the UI: while there are some strings that comes from new
> code (new functions on Calc) there are other strings that are identical to
> the ones on 3.4.1... but on 3.5dev are not translated! For example, under
> "Insertar" (Insert) there is an entry "Movie and Sound" that it is not
> translated on 3.5  (on 3.4.1 says "VĂ­deo y sonido"). Is this something to
> worry about or it is better to wait until 3.5 is on Pootle and everything
> is correctly integrated?

you can expect this with strings that are retrieved using the UNO
command, the UNO command is what identifies every UI feature in the application
framework; you can find them in the XML files that define menu bars and
toolbars in the office installation, for example

grep -r ".uno:InsertAVMedia" /opt/openoffice.org/basis3.4/share/config/soffice.cfg/modules/

Labels for these commands are stored in configuration files. In this
case, ".uno:InsertAVMedia" was moved to the right configuration place:

* 3.4 branch, under Popups:
  http://opengrok.adfinis-sygroup.org/source/xref/aoo-AOO34/main/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu#5352

* trunk under Commands:
  http://opengrok.adfinis-sygroup.org/source/xref/aoo-trunk/main/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu#3075

Strings that were moved to the right category will appear untranslated,
because they are now in fact different strings.
There were also several commands that had the same string but were
placed in different configuration files, these were moved to
GenericCommands.xcu, but you shouldn't note a difference here (only when
translating: several duplicated strings will be removed in 3.5).

So, yes, the Pootle server is in 3.4, the developer snapshots are in
3.5, you'll have to wait until Pootle gets in sync with trunk.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message