incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tapas <tapas...@gmail.com>
Subject Re: Hi, AOO 3.4.1 build breaks in Windows XP
Date Sun, 30 Sep 2012 13:09:34 GMT
Hi Ariel/ALL,

I solved my earlier problem.

Problem was that I checked out svn repository from command prompt in
windows xp. And svn command updated every file with CRLF line endings.

So, when I tried to build using build guide , soltools was giving me errors
like that.

Solution was :

1) check open office build repository using svn command in linux. This way
all file will have LF line ending (as required by unix) .

2) Restart in windows and build the same repository without modifying any
file.

Regards
Tapas

On Mon, Sep 24, 2012 at 7:59 PM, Ariel Constenla-Haile
<arielch@apache.org>wrote:

> Hi,
>
> On Mon, Sep 24, 2012 at 10:51:16AM +0530, tapas wrote:
> > Hi Schrieb/ALL,
> >
> > I also put same things. But I am facing build problem to build it in
> > windows.
>
> note that I've just followed the building guide to set up the
> environment, and it worked with:
>
> * MS Visual C++ 2008 Express Edition
> * MS Driver Kit 7 (for ATL/ActiveX)
> * cygwin set up with http://cygwin.com/setup.exe on Saturday (no idea
>   what version will it be, I assume the latest)
>
>
> > Could please send me atleast below things:
> > 1) configure command
>
> http://people.apache.org/~arielch/packages/r1389156/win/dev/config.cmdops
> http://people.apache.org/~arielch/packages/r1389156/win/dev/config.parms
>
> > 2) cygwin version
>
> I assume the latest, downloaded on Saturday, set up following the
> instructions on the building guide.
>
>
> > 3) out put of configure command in cygwin shell
>
> I didn't save that, but there is the log:
> http://people.apache.org/~arielch/packages/r1389156/win/dev/config.log
>
> > 4) svn revision number of your source tree
>
> rev. 1389156 as the binaries you can find there
> http://people.apache.org/~arielch/packages/r1389156/win/
>
> > 5) contents of cygwin path variable in cygwin shell.
>
> *before* sourcing winenv.set.sh
>
> echo $PATH
> /usr/local/bin:/usr/bin:/cygdrive/c/Windows/system32:/cygdrive/c/Windows
>
> After sourcing winenv.set.sh PATH is set to the value exported in that
> script.
>
>
> > 6) win_env_set.sh file produced by your configure command
>
> http://people.apache.org/~arielch/packages/r1389156/win/dev/winenv.set.sh
>
>
> Regards
> --
> Ariel Constenla-Haile
> La Plata, Argentina
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message