incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@gmail.com>
Subject Re: build svtools with debug
Date Wed, 26 Sep 2012 16:00:38 GMT
On 9/26/12 5:47 PM, Pedro Giffuni wrote:
> Hi Juergen;
> 
> ----- Original Message -----
>> From: Jürgen Schmidt <jogischmidt@gmail.com>
> ...
>>
>> I don't really share your view here and having Windows not buildable
>> with debug is a clear no go for me.
>> You seems to be interested in updating the boost library (which is good)
>> but not interested to solve the upcoming problems in a way that are
>> acceptable for all others who concentrate on other important stuff.
>>  
> 
> I never said I am not interested in solving the problems. At this time
> the buildbot is broken due to many other unrelated issues and it's not
> clear it was my change that caused the reported issue. I am just trying
> to point out where things could've gone wrong.
> 
> Please note that many people did Windows (and linux and MacOSX)
> builds just fine with the new boost. There was a problem similar to the
> one recently reported that was fixed by orw@ but, from what we
> discussed, there was no need to revert the boost update (and yes, I
> did offer to revert it then).
> 
> This said... I am sorry but I don't do Windows and I can't help really
> help there beyond trivial fixes.

yes I know and now we have a further problem that potentially is related
to this.

My main intention is that we agree on a general approach how we can
address such problems in the future. And the easiest way is to do such
changes on a branch first.

Breaking a build bot is not problem as long as we can fix the problems
immediately. Revert otherwise until a better fix is found. Disabling for
example debug support on a platform is of course a problem that we
should take serious and have to avoid.

Juergen

Mime
View raw message