incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regina Henschel <rb.hensc...@t-online.de>
Subject Problems with axial gradient and low color steps
Date Thu, 06 Sep 2012 19:35:54 GMT
Hi all,

I see a lot of problems with axial gradients, but I'm not sure about the 
desired behavior.
Please have look at attachment 
https://issues.apache.org/ooo/attachment.cgi?id=79324 in bug 
https://issues.apache.org/ooo/show_bug.cgi?id=120604

Problem (1): How many color steps has an axial gradient, if the user set 
it to n steps in the UI? Old versions (SO5.2 to at least OOo2.4.3) make 
it in n steps, with n/2 steps blending color "up" and n/2 steps blending 
color "down". Around OOo3.2.1 this behavior was changed so that (n-1) 
steps "up", 1 step in the middle and (n-1) steps down. In AOO we have 
now (n-1) steps "up" and (n-1) steps "down". The ODF does not specify it.

Problem (2): What colors should the steps have? In the old version the 
colors for "up" and "down" where different, what I think has been a bug. 
In AOO 3.4.1 version neither the start not the end color is used, only 
values between.

Problem (3): The old gradients are still used for presentation mode, 
converting to bitmap, export to pdf and flash. I think, that needs to be 
fixed. I have looked around, and think, that it is in 
OutputDevice::ImplDrawLinearGradient in 
\main\vcl\source\gdi\outdev4.cxx. Is that right? If yes, are other 
places effected as well? Should it be fixed or is someone working on a 
more general solution?

Kind regards
Regina


Mime
View raw message