incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [BUILD] atlthunk
Date Sun, 23 Sep 2012 14:46:09 GMT
On Sun, Sep 23, 2012 at 04:27:22PM +0200, Regina Henschel wrote:
> Hi Ariel,
> 
> Ariel Constenla-Haile schrieb:
> >On Sun, Sep 23, 2012 at 04:04:23PM +0200, Regina Henschel wrote:
> >>Hi Ariel,
> >>
> >>should there be "ATL_LIB=" line in winenv.set.sh now?
> >>I ask, because there are still none of the four, but they are listed
> >>in part "unset".
> >
> >If ATL/MFC is detected, they should be set right after DIRECTXSDK_LIB:
> >
> >DIRECTXSDK_LIB="C:/ARCHIV~1/MI599E~1/lib/x86"
> >ATL_LIB="C:/ARCHIV~1/MICROS~1.0/VC/atlmfc/lib"
> >ATL_INCLUDE="C:/ARCHIV~1/MICROS~1.0/VC/atlmfc/include"
> >HAVE_ATLTHUNK="NO"
> >MFC_LIB="C:/ARCHIV~1/MICROS~1.0/VC/atlmfc/lib"
> >MFC_INCLUDE="C:/ARCHIV~1/MICROS~1.0/VC/atlmfc/include"
> >
> >
> >Is ATL/MFC detected at all? Please post the output of configure after
> >
> >checking for DirectX SDK files... found
> >checking for ATL and MFC... configure: testing ATL/MFC libs and includes
> >
> 
> No, I get
> checking for DirectX SDK files... found
> checking for ATL and MFC... ATL/MFC disabled

Did you run autoconf?
If you look at configure.in ca. line 5747, where the check start:

dnl ============================================
dnl Check for ATL and MFC
dnl ============================================


It looks like you don't pass the first check:

if test \( "$_os" = "WINNT" \) ; then
    AC_MSG_CHECKING([for ATL and MFC])

you pass this check, but not the following:


    if test "$DISABLE_ATL" = "TRUE" -o "$DISABLE_ACTIVEX" = "TRUE" ; then
        AC_MSG_RESULT([ATL/MFC disabled])


because in all further checks I added some AC_MSG_NOTICE that should
tell you where the error is. Looks like you have ATL or ActiveX
disabled, or this check isn't working at all.

DISABLE_ATL is set with the following check, ca. line 1534:


   AC_MSG_CHECKING([whether to use ATL])
   if test "$enable_atl" = "yes" -o "$enable_atl" = "TRUE" -o "$enable_atl" = ""; then
       DISABLE_ATL=""
       AC_MSG_RESULT([yes])
   else
       DISABLE_ATL="TRUE"
       AC_MSG_RESULT([no])
   fi
   AC_SUBST(DISABLE_ATL)


This means, ATL is disabled only if you configure with --disable-atl
The same is valid for ActiveX.


> checking for NSIS... checking for nsis.exe... no
> 
> >In case you see a
> >
> >configure: looking for atlbase.h in "/cygdrive/c/ARCHIV~1/MICROS~1.0/VC/atlmfc/include
> >
> >it will test if this header exists in this folder, and so on.
> 
> Is any of my log files useful for you?
> 
> Are there files, which I should delete, to make sure, that no old
> ones are used?

You have to run autoconf, but this is checked AFAIK configure checks if
it is older than configure.in.

You can also look at config.log, config.params has the parameters info,
and should be the same as in config.log.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message