incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: icon issues with 3.4.x on Linux with KDE 4
Date Fri, 03 Aug 2012 22:51:53 GMT
Hi Ricardo,

On Fri, Aug 3, 2012 at 7:38 PM, RGB ES <rgb.mldc@gmail.com> wrote:
>> It was Philipp Lohmann, at it's at
>> http://hg.services.openoffice.org/cws/kde4enable/
>>
>>
>> Regards
>
> Is this kde4 integration the same used by openSUSE on their LibO
> version? Because that "integration" is not good: it offers the kde
> file picker, yes, but the "look and feel" it provides is completely
> wrong and historically it caused a lot of trouble: if you look at
> openSUSE's forums you'll see many threads about problems with their
> LibO that were solver by uninstalling the KDE4 "integration"
> package...

this CWS was more about making it possible to build with --enable-kde4
on Hamburg (I don't know what system they used to build, but it didn't
have KDE4 libraries, IIRC what Philipp wrote once). The code in that
CWS may not differ too much from what we have here. AOO does not build
with KDE integration because the vcl plugin [simplifying, this plugin
paints the user interface making it look like a KDE application] is
rather broken (last time I built it, it had several painting issues).

So, unless someone with deep knowledge of QT4/KDE4 joins here, it's
very likely that AOO will remain a Gnome2 application on Linux (yes,
we also need someone with Gtk3/Gnome3 knowledge).


Regards

Mime
View raw message