incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ZuoJun Chen <zjchen...@gmail.com>
Subject Re: Building OpenOffice with Visual Studio 2010
Date Wed, 29 Aug 2012 01:52:36 GMT
Cool! I have interesting in building Apache OpenOffice with Clang on Mac
OS, hope that I

can get some inspiration from your experiment:)

Currently  If using --without-stlport config parameter on  Mac OS 10.7, it
will replace with

system stl implement and could build successfully with gcc, even there are
other things

that needed to be done for build with Clang:(

2012/8/28 Ian Harvey <ian_harvey@bigpond.com>

> I have been experimenting with building OpenOffice (trunk) with Visual
> Studio 2010.  I have made some progress, but clearly more work remains.  Is
> there an appropriate place to document/share/seek advice on progress to
> date within the projects' infrastructure? Perhaps an issue in Bugzilla?
>
> Navigating the build system has been challenging.  Pointers to information
> to highlight how the build system works (so that any changes to accomodate
> VS2010 I make don't work contrary to the intent of its designers) would be
> appreciated.
>
> The use of stlport by the Windows build causes some of the issues that I
> have encountered, perhaps through ignorance on my part about how stlport
> should be used.  Is the intention to continue using stlport, or should I
> investigate excising stlport from a hypothetical VS2010 build?
>
> Thanks for any advice,
>
> IanH
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message