incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Pescetti <pesce...@apache.org>
Subject Re: [INFO][WEBSITE]: improved usability with simplified Urls to reach some of our services
Date Tue, 14 Aug 2012 23:41:06 GMT
On 14/08/2012 RGB ES wrote:
> 2012/8/14 RGB ES:
>> Good! But I'm finding a weird behaviour on the forums... If I enter on
>> the old url
>> http://user.services.openoffice.org/
>> I'm NOT redirected. If I open bot, the new and the old address and
>> log-in in the new, in the old one I'm still logged off

I would consider this to be normal behavior. Authentication is probably 
managed through a cookie that is sent back to the originating site (the 
originating subdomain) only. So user.services.openoffice.org has no way 
to know that you are logged in at forum.openoffice.org, unless we 
completely rewrite all URLs in the form 
user.services.openoffice.org/SOMETHING to forum.openoffice.org/SOMETHING .

> Not only confusing, but also problematic: if you log-in on the new
> address and then click on an old link that cross reference to another
> post you'll arrive to a page on which you are not logged in any
> more!

If we have hardcoded links that are not rewritten (i.e., if pages on 
forum.openoffice.org contain "internal" links that reference 
user.services.openoffice.org explicitly), then it would be better to use 
an "external" redirect as explained above.

Regards,
   Andrea.

Mime
View raw message