incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From imacat <ima...@mail.imacat.idv.tw>
Subject Re: [RELEASE][3.4.1]: potential release blocker
Date Thu, 02 Aug 2012 14:23:20 GMT
On 01.08.02 07:31pm, Jürgen Schmidt said:
> On 8/2/12 12:58 PM, Jürgen Schmidt wrote:
>> On 8/2/12 12:46 PM, Jürgen Schmidt wrote:
>>> On 8/2/12 12:24 PM, Dave Fisher wrote:
>>>>
>>>> On Aug 2, 2012, at 2:15 AM, Jürgen Schmidt wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> imacat found a problem with the base application icon on windows.
>>>>>
>>>>> I can verify this issue with the latest version based on r1367911 when
I
>>>>> do a clean fresh installation, no upgrade. If you run an upgrade
>>>>> installation you don't see this problem and the icon is ok.
>>>>
>>>> You have the answer to the question I asked imacat just now.
>>>>
>>>> BTW - did you notice that the Draw icon was also missing in her screenshot?
>>>
>>> no, I haven't noticed this, I was focused on the base icon ;-)
>>
>> and I know why I haven't noticed it, I have checked it again on my
>> Windows machine and the only icon that is missing is that from Base ;-)
>>
>> I hate such problems...
> 
> I am still have no real idea what going wrong and I am rebuilding
> currently the same version to ensure that it is no build problem (but I
> hope it is :-)).
> 
> As I mentioned earlier when you watch the properties, you will see the
> correct icon. When you now click on change icon and double click the
> icon (which is the only available icon in sbase.exe) and apply the
> change everything is ok in the Start Menu.
> 
> Even a restart of windows after the installation won't help.
> 
> I am no expert but I would guess that the icon in the Start Menu is
> extracted from the exe where it seems to be ok.

    Thanks, Jürgen.  I think this issue is serious in that:  It drew my
attention not from the inside of the start menu, but from the recent
applications shortcuts of the start menu.  See the attached picture.
Windows 7 puts the first shortcut of the most recent installed
application, at the recent application shortcuts of the start menu.  It
is very large and obvious when user wants to run anything in Windows 7.

    A detaled explanation of my case: I first upgraded from 3.4.0 to
3.4.1, and found this problem (alone with Draw).  Then I removed the
previous version and did a clean install, and this problem still exists
(alone with Draw).

    I layed the icons a bit.  It seems that the Base shortcut only have
problem when the icon is read from sbase.exe.  The shortcut icon of
Base.lnk is fine if it is from scalc.exe, sdraw.exe or anything else.
The same goes for Draw.lnk:  It only has problem when points to
sdraw.exe, but not the others (sbase.exe, smath.exe, etc.)  Any other
shortcuts (even those created by hand) work fine for both sbase.exe and
sdraw.exe.

    So I suppose the problem lies in the shortcut files Base.lnk and
Draw.lnk.  How do we create these two files?  Shall we create them again?

-- 
Best regards,
imacat ^_*' <imacat@mail.imacat.idv.tw>
PGP Key http://www.imacat.idv.tw/me/pgpkey.asc

<<Woman's Voice>> News: http://www.wov.idv.tw/
Tavern IMACAT's http://www.imacat.idv.tw/
Woman in FOSS in Taiwan http://wofoss.blogspot.com/
Apache OpenOffice http://www.openoffice.org/
EducOO/OOo4Kids Taiwan http://www.educoo.tw/

Mime
View raw message