incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: svn commit: r1357306 - /incubator/ooo/trunk/main/solenv/bin/build.pl
Date Sat, 25 Aug 2012 20:21:03 GMT
On Sat, Aug 25, 2012 at 12:55:35PM -0300, Ariel Constenla-Haile wrote:
> > >> this particular change is incompatible with my build system. I do
> > >> [meta-shell code]:
> > > 
> > > I should have explained this change better (or at all).  It is only
> > > intended as a temporary hack to find out the reason for the build
> > > breaker of the 64bit Linux buildbot build.
> > 
> > is the problem already solved?  -- Pavel Janík
> 
> It is not solved. The main bug with it, is that now it hides where the
> build is breaking; I faced it yesterday on my own build, and now it can
> be seen in the Win build bot: the build continues regardless any error
> on any module, and breaks in instsetoo_native due to missing compiled
> stuff:
> 
> http://ci.apache.org/projects/openoffice/buildlogs/win/main/instsetoo_native/wntmsci12.pro/misc/logs/util.txt
> 
> Even worst, the build bot only reports an error when trying to copy the
> install sets generated in instsetoo_native
> http://ci.apache.org/builders/aoo-win7/builds/281/steps/MasterShellCommand_1/logs/stdio


The problem is that they system call now pipes the build command:

$error_code = system ("$job_to_do 2>&1 | tee $log_file");

and tee returns always 0, hiding the $job_to_do error code.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message