incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <>
Subject Re: [DISCUSS][VOTE]: Release Apache OpenOffice 3.4.1 (incubating), RC2
Date Thu, 16 Aug 2012 10:48:00 GMT
On Thu, Aug 16, 2012 at 09:30:13AM +0200, Andre Fischer wrote:
> >Sorry, I'm a bit cranky right now. My cpan disappeared while trying
> >to assure that I had the now required LWP::UserAgent. No one tested
> >the new properly.
> 1. LWP::UserAgent has been a prerequisite for years.  But I think
>    I remember that it was temporarily removed from one of the older
>    platform specific build instruction pages.
> 2. Can you be more specific regarding your problems with
> so that I can fix it?  It exists
>    under this name for more than two months and since it is used in
>    every setup of a build I would say that it is fairly well tested.
>    But that does not mean that it is error free.

He might have found something similar to this:

He has LWP::UserAgent but it's too old, a method is missing, so he tries
to update the module with cpan. Updating Perl like this may brake other
things in your system, I prefer keeping the system as it came, and
install a local perl version.

IMO there is no fix for this: we check the perl version, we check the
presence of LWP::UserAgent, but: does it make sense to check the
LWP::UserAgent version too? Is it possible at all? The perl module does
not document when a specific method was introduced, or I least
I couldn't find that info in there
is not such thing as a @since tag.

Ariel Constenla-Haile
La Plata, Argentina

View raw message