incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tsutomu Uchino <hanya.r...@gmail.com>
Subject Re: [BUILDBOT] build breakers
Date Fri, 06 Jul 2012 15:30:15 GMT
2012/7/6 Andre Fischer <af@a-w-f.de>:
> Here is a quick update on the status of the buildbots:
>
> - Windows7 still breaks because it attempts to use the compiler from Visual
> Studio 2010 instead of the officially supported one from 2008.
>
> - Linux 32bit is OK.
>
> - Linux 64bit has a strange, Java related problem.  With Herbert's help I
> have changed the build.pl script a little bit so that we get the dmake
> output even when the buildbot terminates the build process.  With that we
> have found out that the build most often (2 times in the last 3 days) when
> building javadoc.
> The cause of the hang remains unknown.  Any help by Java-experts is welcome.
This is not a solution but we do not need javadoc  for httpclient so
it can omit to build like as follows:
diff -u misc/build.xml misc/build/commons-httpclient-3.1/build.xml
--- misc/build.xml	2007-08-18 18:02:14.000000000 +0900
+++ misc/build/commons-httpclient-3.1/build.xml	2012-07-07
00:21:06.331136658 +0900
@@ -142,7 +142,7 @@

 <!-- ========== Targets: "External" Targets =============================== -->

-  <target name="dist" depends="compile,doc"
+  <target name="dist" depends="compile"
           description="Create binary distribution">
     <mkdir dir="${dist.home}"/>
     <copy file="LICENSE.txt" todir="${dist.home}"/>

>
> The log file of the Linux 64bit can be found here:
>
> http://ci.apache.org/builders/openoffice-linux64-nightly/builds/279/steps/shell_1/logs/stdio
>
> Go to the end and find the last non-blue (shall I say black?) lines.
>
> -Andre

-Tsutomu

Mime
View raw message