incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer ...@a-w-f.de>
Subject Re: [RELEASE] [3.4.1] Bug 119229 as blocker (download new versions of extensions)
Date Mon, 02 Jul 2012 13:26:46 GMT
On 28.06.2012 13:29, Andrea Pescetti wrote:
> On 25/06/2012 J├╝rgen Schmidt wrote:
>> On 6/24/12 4:30 PM, Andrea Pescetti wrote:
>>> This bug only affects the build infrastructure, but I propose it as a
>>> blocker for 3.4.1:
>>> https://issues.apache.org/ooo/show_bug.cgi?id=119229
>>> Unless the build process starts completely clean (and it didn't as of
>>> the 3.4.0 builds), the build would reuse an older, cached, version of
>>> the extension even if a newer one was specified in extensions.lst
>> I can see a benefit for the source release but not very critical. But
>> don't see the demand for our binary release because we can easy check it.
>
> If the build system has been improved and binary builds provided by the
> project are now fine (in OpenOffice 3.4.0 the build system did not
> cleanup previously downloaded extensions, resulting in the Spanish and
> Italian dictionaries not being updated), it's of course OK for me. What
> I'd like to ensure is just that this doesn't happen with the current
> build process, otherwise it might be better to backport the fix.

Like Juergen, I see this as nice to have but not as critical.

>
>> If somebody volunteers to include, built and test it for 3.4.1 then I
>> would support it.
>> Any volunteer?
>
> I might have a look, but only in the pre-build phase (which should be
> enough: you don't need to fully build the office to check what version
> of the extension is downloaded).

Well, you might want to make sure that the extension is properly 
recognized and added when the install set is created (at the very end of 
the build process.)  But I agree that checking that configure and 
bootstrap work are probably enough.

-Andre

Mime
View raw message