incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro Giffuni <...@apache.org>
Subject Bug 119384 : Python update coming after 3.4.1 release
Date Wed, 25 Jul 2012 22:20:44 GMT
Hello guys;

With some help from Hanya I have been slowly working on an update
to our internal Python. The patch is rather big but it is necessary
because:

- The older 2.6.1 python is basically unsupported upstream.
- Newer versions of python have better performance and solve
security issues.
- The world will be moving at some point to Python 3 and as
part of the migration path the Python developers have been adding
some compatibility in late 2.6.x and 2.7.x versions.

The update takes python to version 2.7.3 which means nothing
will break but we can start using some Python 3 features.

Unfortunately, due to some brokenness in GNU patch which
cannot handle some CRLF changes upstream, we will lose
a change to support SSL on the internal python but it doesn't
seem critical at this time.

I am still running a complete build under FreeBSD and, of course,
I have no interest in breaking the tree while everyone is
busy rolling 3.4.1 so I will leave the update for after the release.

For now I will leave the big patch in BZ i119384 JIC there are
brave testers interested.

regards,

Pedro.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message