resent the attachment. Thanks for your reminder!

2012/6/1 Peng Chen <chenpeng2006@gmail.com>
Can't see the attachement.

2012/6/1 Chao Huang <chao.dev.h@gmail.com>

> hi, all
>
> I checked out the source code from SVN server
> (https://svn.apache.org/repos/asf/incubator/ooo/trunk) and the
> revision is 1343441.
>
> It's OK for me to make a full build on Mac OS X 10.6.8. But there is a
> build break on Mac OS X 10.5.8. Please note that I used the same code
> package and configure switchers.
>
> The build break was reported in module SAL. Here is the details
>
> ------------------------------------------------------------------------------------------------------------------------------
> Entering
> /Users/hchao/Apache/build/aoo.340.20120601/aoo.340.r1343441/main/sal/util
>
> ERROR: error 10 occurred while making
> /Users/hchao/Apache/build/aoo.340.20120601/aoo.340.r1343441/main/sal/util
>
> -------------------------------------------------------------------------------------------------------------------------------
>
> My dev env is :
> ---------------------------------------------
> 1) Mac OS X 10.5.8
> 2) Xcode 3.0
> 3) gcc 4.0.1
> 4) jdk 1.5
> ---------------------------------------------
>
> I used the following configure swithcers.
>
> --------------------------------------------------------------------------------------------------------------------------------
> ./configure --with-dmake-url="
> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
> --with-epm-url="http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz"
> --disable-mozilla --disable-build-mozilla --enable-verbose
> --enable-category-b --enable-minimizer --enable-presenter-console
> --enable-wiki-publisher --disable-odk
>
> --------------------------------------------------------------------------------------------------------------------------------
>
> At the beginning of this year, I passed the full build on both 10.5
> and 10.6 with R1189933. So I compared file main/sal/util/makefile.mk.
> There is only one changed line for OS2 except license. The build break
> can be solved by recovering makefile.mk from R1343441 to R1189933.
>
> What I do in the next step is to copy makefile.mk (R1343441) from
> MacOSX to WindowsXP, then convert the file format from DOS to Unix by
> UltraEdit, copy the new file makefile.mk back to MacOSX. It's OK to
> rebuild module SAL with the new makefile.mk.
>
> So I guess that there is something wrong for file
> main/sal/util/makefile.mk. Maybe the file is broken in some extent.
> The size of original file is 5.76K, while the re-saved one is 5.53K.
> Please refer to the attachement.
>
> Is there anyone who can help to confirm this issue? Thanks!
>
>
> Best regards,
> Chao Huang
>



--
Best regards,
Chao Huang