incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lou ql <louqin...@gmail.com>
Subject Re: [QE]3.4.1 snapshot builds installation testing
Date Tue, 26 Jun 2012 08:16:14 GMT
On Tue, Jun 26, 2012 at 2:57 PM, Ariel Constenla-Haile
<arielch@apache.org>wrote:

> Hi lou ql
>
> On Tue, Jun 26, 2012 at 02:30:12PM +0800, lou ql wrote:
> >    Today I tested RPM build r1351960:
> >
>  Apache_OpenOffice_incubating-Dev_AOO341m1_Linux_x86_install-rpm_en-US.tar.gz
> >
> >    There are no desktop-integration rpm packages...
>
> This is as designed: Developer Snapshot builds do not have
> system/desktop integration (yes, the naming we've been using is rather
> confusing, because we've been naming betas with desktop integration also
> Dev. Snapshots, and we've been placing them all in the same page - IMHO
> something we should fix in the future, in OOo times the distinction
> between Dev. Snaps. - builds from trunk - and alphas/betas
> - builds from current release branch - was more clear).
>
> >    installed on redhat 6.1 and suse 11:
> >    1. install: rpm -ivh *.rpm, pass
> >    2. version No. in help->about panel is 3.4.1
> >    3. package name list by command "rpm -qa | grep ooo" contains "3.4.1"
> >    4. launch from /opt/ooo-dev3/program/soffice, works
> >    5. bundled Extensions: 5 English dictionaries, Presentation Minimizer,
> >    Presenter Console
> >    6. English dic works: red wave lines under misspelled words,
> suggestions
> >    appears in context menus
> >    7. a module about CoinMP library exists in
> >    /opt/ooo-dev3/share/readme/NOTICE file
> >    8. help->check for Update failed. I attached the screenshot
>
> yes, this is a non existent URL:
>
> http://www.openoffice.org/projects/update/aoo341/check.Update?pkgfmt=rpm
> does not exist.
>
> >    9. no quickstarter
>
> You have to enable it:
> Tools - Options... - OOo-Dev - Memory - check "Enable systray
> Quickstarter"
>
>
I enable the quickstarter and encountered a crash: *Bug
120095*<https://issues.apache.org/ooo/show_bug.cgi?id=120095>

The crash also exists in Aoo 3.4, but since the Quickstarter is disabled in
3.4.1 by default, and those who like it being enabled will encounter this
crash more easier, I propose this as release block


> >    10. remove: rpm -e `rpm -qa | grep ooo`, pass
> >
> >    not try upgrade:
> >    1: 3.4 not support upgrade on linux
> >    2: the snapshot build has different package name and cannot replace
> the
> >    released openoffice
>
> this two are obvious: this is a Developer Snapshot, it is not supposed
> to update the current default installation (though in theory it should
> update any other previous Developer Snapshot - "in theory" == update is
> completely broken on Linux, a full removal is required).
>
>
> Regards
> --
> Ariel Constenla-Haile
> La Plata, Argentina
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message