incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: [BUILDBOT] build breakers
Date Fri, 29 Jun 2012 09:16:36 GMT
Hi Chao Huang,

On Fri, Jun 29, 2012 at 6:07 AM, Chao Huang <chao.dev.h@gmail.com> wrote:
> The full build broke on Mac OS X 10.6.8.
>
> MacOSX 10.6.8
> --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> gcc version 4.2.1 (Apple Inc. build 5666) (dot 3)
> java version "1.6.0_33"
>
>
> configure switchers
> --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> ./configure --with-dmake-url="
> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
> --with-epm-url="http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz"
> --disable-mozilla --disable-build-mozilla --enable-category-b
> --enable-minimizer --enable-presenter-console --enable-wiki-publisher
>
> Break Info
> --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> ignoring silgraphite-2.3.1.tar.gz because its prerequisites are not
> fulfilled
> bsh-2.0b1-src.tar.gz exists, MD5 checksum is OK
> downloading 1 missing tar balls to
> /Users/hchao/Apache/build/aoo.340.20120629/code/ext_sources
> downloading to
> /Users/hchao/Apache/build/aoo.340.20120629/code/ext_sources/377a60170e5185eb63d3ed2fae98e621-README_silgraphite-2.3.1.txt.part
> Can't locate object method "show_progress" via package "LWP::UserAgent" at


Your Perl is too old, I've seen this too on CentOS 5:

Can't locate object method "show_progress" via package
"LWP::UserAgent" at
/build/aoo/src/clean/trunk/main/solenv/bin/modules/ExtensionsLst.pm
line 484.

CentOS Perl:
]$ /usr/bin/perl --version

This is perl, v5.8.8 built for i386-linux-thread-multi

CentOS perl-libwww-perl-5.805-1.1.1.noarch
]$ /usr/bin/perl -MLWP::UserAgent -e 'print "$LWP::UserAgent::VERSION\n"'
2.033


As you see, the UserAgent version is too old, and does contain that
method show_progress

On Fedora 17:
]$ /usr/bin/perl -MLWP::UserAgent -e 'print "$LWP::UserAgent::VERSION\n"'
6.03

It looks like we need to ckeck not only Perl version but also
LWP::UserAgent::VERSION

You can fix this by not using system perl (I've done this on CentOS,
but needs more tweaking).

Regards

Mime
View raw message