incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noah Tilton <noahktil...@gmail.com>
Subject Re: ODF Command Line Tools -- Request for community feedback
Date Fri, 01 Jun 2012 23:54:49 GMT
Rob,

I have thoroughly investigated Maven.  It is not immediately clear to
me how one would use Maven for a jruby project.  Apache Buildr seems a
better fit, but in my view neither is as easy as it should be.  And
whether we use Maven or buildr or $X, people will still have to
manually install jruby.

I'm not saying we can't/shouldn't use a build tool, just that I spent
way too much time this week fighting to make one work and failed
miserably.

So, I wrote a very simple (20-line) bash script which downloads jars
and sets local shell variables, to make the example I sent to you
previously work.  As long as you have wget, java, and jruby installed,
you should be able to run

% ./test.sh

And see an immediate working result.  If that is not the case, please
let me know.

https://github.com/noah/odf-command-line-tools

My plan is to get the DSL working and worry about making the build
scripts pretty later.  If it works with standard Linux tools, that
should be doable.  Please let me know your thoughts.

Thanks,
-Noah

On Tue, May 29, 2012 at 3:50 AM, Rony G. Flatscher (Apache)
<rony@apache.org> wrote:
>
> On 5/29/2012 3:49 AM, Fernando Cassia wrote:
>> On Mon, May 28, 2012 at 4:21 PM, Rob Weir <robweir@apache.org> wrote:
>>
>>> For example, does
>>> JRuby pre-req a JDK version?
>>>
>>> -Rob
>>>
>> I am 100% sure it runs both on the propietary Java one gets from java.com,
>> (1.6 onwards, including JDK7) and also on OpenJDK (1.7 here on Linux).
>>
>> I know because I have run JRuby on both. It' s safe to say JRE or JDK 1.6
>> or higher is a requirement. All previous Java versions are EOL' d.
> If possible at all, the base line support should be Java 1.4 as long as possible as there
are still
> quite a few Java deployments at that level (also 1.5) in the market despite Sun/Oracle
putting the
> EOL death spell on Java 1.4 and 1.5. (Of course, support for 1.4 can only be granted,
if it is
> possible to compile the ODF toolkit for target 1.4 and not using Java methods only available
in Java
> 1.5 or higher, as <http://incubator.apache.org/odftoolkit/odftoolkit-release-guide.html>
mandates
> 1.5 as a minimum JDK level.)
>
> ---rony
>



-- 
Noah

Mime
View raw message