incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zhangjf <zhan...@apache.org>
Subject Re: [BUILD] There is a build break on Mac OS X 10.5.8
Date Mon, 04 Jun 2012 08:42:21 GMT
I have already committed the fix to trunk for huangchao.

On Mon, Jun 4, 2012 at 4:26 PM, Chao Huang <chao.dev.h@gmail.com> wrote:
> The line end flag is "0x0D 0x0A" in original file "main/sal/util/makefile.mk",
> which is a windows style. It should be a unix style like "0x0A".
>
> What make me confused is that it only lead to build break on MacOSX 10.5.8.
>
> 2012/6/4 Chao Huang <chao.dev.h@gmail.com>
>
>> hi, Herbert
>>
>> I tried to build module SAL with flag "verbose=t". There is the same error
>> message
>>
>> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>>
>> Entering
>> /Users/hchao/Apache/build/aoo.340.20120601/aoo.340.r1343441/main/sal/util
>>
>> ERROR: error 10 occurred while making
>> /Users/hchao/Apache/build/aoo.340.20120601/aoo.340.r1343441/main/sal/util
>>
>> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>>
>> I'm sure that the file "main/sal/util/makefile.mk" is broken in some
>> extent. I created a new file, copied the contents from "main/sal/util/
>> makefile.mk" to it, then replace "main/sal/util/makefile.mk" with it.
>> It's OK to build module SAL with the new file.
>>
>>
>>
>> 2012/6/1 Herbert Duerr <hdu@apache.org>
>>
>>> Hello Chao Huang,
>>>
>>>
>>>  The build break was reported in module SAL. Here is the details
>>>> ------------------------------**------------------------------**
>>>> ------------------------------**------------------------------**------
>>>> Entering /Users/hchao/Apache/build/aoo.**340.20120601/aoo.340.r1343441/*
>>>> *main/sal/util
>>>>
>>>> ERROR: error 10 occurred while making
>>>> /Users/hchao/Apache/build/aoo.**340.20120601/aoo.340.r1343441/**
>>>> main/sal/util
>>>>
>>>
>>> I suggest to:
>>>
>>> cd /Users/hchao/Apache/build/aoo.**340.20120601/aoo.340.r1343441/**
>>> main/sal/
>>> build verbose=t
>>>
>>> and then report the errors here. Please note that attachments seem to get
>>> stripped on this mailing list.
>>>
>>> Herbert
>>>
>>
>>
>>
>> --
>> Best regards,
>> Chao Huang
>>
>>
>
>
> --
> Best regards,
> Chao Huang

Mime
View raw message