incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chao Huang <chao.de...@gmail.com>
Subject Re: [BUILDBOT] build breakers
Date Fri, 29 Jun 2012 09:07:07 GMT
The full build broke on Mac OS X 10.6.8.

MacOSX 10.6.8
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
gcc version 4.2.1 (Apple Inc. build 5666) (dot 3)
java version "1.6.0_33"


configure switchers
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
./configure --with-dmake-url="
http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2"
--with-epm-url="http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz"
--disable-mozilla --disable-build-mozilla --enable-category-b
--enable-minimizer --enable-presenter-console --enable-wiki-publisher

Break Info
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ignoring silgraphite-2.3.1.tar.gz because its prerequisites are not
fulfilled
bsh-2.0b1-src.tar.gz exists, MD5 checksum is OK
downloading 1 missing tar balls to
/Users/hchao/Apache/build/aoo.340.20120629/code/ext_sources
downloading to
/Users/hchao/Apache/build/aoo.340.20120629/code/ext_sources/377a60170e5185eb63d3ed2fae98e621-README_silgraphite-2.3.1.txt.part
Can't locate object method "show_progress" via package "LWP::UserAgent" at
/Users/hchao/Apache/build/aoo.340.20120629/code/main/solenv/bin/
download_external_dependencies.pl line 506, <$in> line 353.

dmake present in
/Users/hchao/Apache/build/aoo.340.20120629/code/main/solenv/
unxmacxi.pro/bin/dmake
bundling of dictionaries is disabled.
HuangChaos-iMac-106:main hchao$



2012/6/22 Andre Fischer <af@a-w-f.de>

> Hi,
>
> there are build breakers on all three platforms
>
> - Windows7
>
> in shell_2:
>
> has ./configure: line 7952: test: : integer expression expected
> ./configure: line 7957: test: : integer expression expected
> ./configure: line 7962: test: : integer expression expected
> configure: error: Compiler too old. Use Microsoft C/C++ .NET 2003/2005
> compiler.
>
> could be caused by missing DLLs when the compiler is called to detect its
> version.  In that case cl does not print anything.  I have seen something
> similar when I tried to use the 2010 dev studio.
>
>
> - Linux64
>
> in compile_2 there is the line
>
> ./configure: line 11931: test: : integer expression expected
>
> @Andrew: can you post the config.log and configure files so that we can
> better analyze the cause of this bug?
>
>
> - Linux32
>
> the build breaker seems to be caused by my recent changes in
> ext_libraries/serf.  It may be sufficient to make a clean build.
>
> @Andrew: can you trigger that?
>
>
> Regards,
> Andre
>



-- 
Best regards,
Chao Huang

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message