incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer ...@a-w-f.de>
Subject Re: [BUILDBOT] build breakers
Date Fri, 29 Jun 2012 08:50:14 GMT
On 29.06.2012 10:42, zhangjf wrote:
> I don't know here which distribution linux32 refers to.  Our build on
> SuSe 11.1 breaks on serf 1.1 because it has a new dependency on
> libexpat.so,  we resolved it by installing the libexpat-devel rpm
> package.

That should only be necessary if you are using --with-system-serf.
Otherwise the external version should be used.  I probably broke that 
when I added the --with-system-serf switch.

-Andre

>
> zhangjf
>
> On Fri, Jun 22, 2012 at 5:37 PM, Andre Fischer <af@a-w-f.de> wrote:
>> Hi,
>>
>> there are build breakers on all three platforms
>>
>> - Windows7
>>
>> in shell_2:
>>
>> has ./configure: line 7952: test: : integer expression expected
>> ./configure: line 7957: test: : integer expression expected
>> ./configure: line 7962: test: : integer expression expected
>> configure: error: Compiler too old. Use Microsoft C/C++ .NET 2003/2005
>> compiler.
>>
>> could be caused by missing DLLs when the compiler is called to detect its
>> version.  In that case cl does not print anything.  I have seen something
>> similar when I tried to use the 2010 dev studio.
>>
>>
>> - Linux64
>>
>> in compile_2 there is the line
>>
>> ./configure: line 11931: test: : integer expression expected
>>
>> @Andrew: can you post the config.log and configure files so that we can
>> better analyze the cause of this bug?
>>
>>
>> - Linux32
>>
>> the build breaker seems to be caused by my recent changes in
>> ext_libraries/serf.  It may be sufficient to make a clean build.
>>
>> @Andrew: can you trigger that?
>>
>>
>> Regards,
>> Andre


Mime
View raw message