incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer>
Subject Re: The new
Date Tue, 05 Jun 2012 07:39:09 GMT
Hi Herbert,

On 05.06.2012 07:25, Herbert Duerr wrote:
> Hi Andre,
> thanks for the great work which will help us very much to clean up the
> bootstrap process.
>> ... is called
> I don't like the file names "" and
> "external_libs.lst" because what is actually downloaded is more than
> just libraries. It already downloads such things a fonts, AFM files and
> some license texts.
> We have more than enough cases in our code base where code evolution
> caused a mismatch of names to reality. New functionality that was
> created from scratch should not start with having a misleading name.
>> It is a rewrite in Perl with the following improvements:
>> [lots of wonderful benefits snipped]
>> The download script is main/solenv/bin/
> How about naming that or *
>> The data file has a new format and I took the opportunity to rename it
>> to main/external_libs.lst. [...]
> How about naming that download_external_deps.lst or *_dependencies.lst?

Good idea.  I will rename to


     external_libs.lst to external_deps.lst

when I make the new download mechanism the default in a few days.


>> I hope this helps in our quest to solve the category-B questions.
> It sure does. Thanks again!
> Herbert

View raw message