incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Herbert Duerr <...@apache.org>
Subject Re: The new fetch_tarballs.sh
Date Tue, 05 Jun 2012 05:25:39 GMT
Hi Andre,

thanks for the great work which will help us very much to clean up the 
bootstrap process.

> ... is called download_external_libraries.pl.

I don't like the file names "download_external_libraries.pl" and 
"external_libs.lst" because what is actually downloaded is more than 
just libraries. It already downloads such things a fonts, AFM files and 
some license texts.

We have more than enough cases in our code base where code evolution 
caused a mismatch of names to reality. New functionality that was 
created from scratch should not start with having a misleading name.

> It is a rewrite in Perl with the following improvements:
> [lots of wonderful benefits snipped]
> The download script is main/solenv/bin/download_external_libraries.pl.

How about naming that download_external_deps.pl or *_dependencies.pl?

> The data file has a new format and I took the opportunity to rename it
> to main/external_libs.lst. [...]

How about naming that download_external_deps.lst or *_dependencies.lst?

> I hope this helps in our quest to solve the category-B questions.

It sure does. Thanks again!

Herbert

Mime
View raw message