incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer ...@a-w-f.de>
Subject Re: Buildbreaker in instsetoo_native on Mac OS X and Solaris Sparc
Date Mon, 04 Jun 2012 15:20:13 GMT
On 04.06.2012 16:09, Raphael Bircher wrote:
> Am 04.06.12 16:05, schrieb Andre Fischer:
>>
>>
>> On 04.06.2012 08:11, Raphael Bircher wrote:
>>> Hi all
>>>
>>> I have a buildbreaker on instsetoo_native  if I build /ooo/trunk/
>>>
>>> ------------------- Breaker log -----------------------
>>>
>>> Entering /Users/server3/Documents/build59/main/instsetoo_native/util
>>>
>>> dmake:  makefile.mk:  line 193:  Warning: -- Prior to dmake 4.5 only one
>>> %-target per target-definition worked reliably. Check your makefiles.
>>>
>>> /opt/local/bin/perl -w
>>> /Users/server3/Documents/build59/main/solenv/bin/make_installer.pl -f
>>> ../util/openoffice.lst -l en-US -p OpenOffice -u ../unxmacxi.pro
>>> -buildid 9590 -msitemplate ../unxmacxi.pro/misc/openoffice/msi_templates
>>> -msilanguage ../unxmacxi.pro/misc/win_ulffiles -format archive
>>> Subroutine installer::epmfile::getcwd redefined at
>>> /Users/server3/Documents/build59/main/solenv/bin/modules/installer/epmfile.pm
>>>
>>> line 39
>>> ... checking environment variables ...
>>>
>>> ########################################################
>>> make_installer.pl, version 1.0
>>> Product list file: ../util/openoffice.lst
>>> Taking setup script from solver
>>> Unpackpath:
>>> /Users/server3/Documents/build59/main/instsetoo_native/util/../unxmacxi.pro
>>>
>>> Compiler: unxmacxi
>>> Product: OpenOffice
>>> BuildID: 9590
>>> Build: AOO340
>>> No minor set
>>> Product version
>>> Using default installpath
>>> Package format: archive
>>> msi templatepath:
>>> /Users/server3/Documents/build59/main/instsetoo_native/util/../unxmacxi.pro/misc/openoffice/msi_templates
>>>
>>> msi template path will be ignored for non Windows builds!
>>> msi languagepath:
>>> /Users/server3/Documents/build59/main/instsetoo_native/util/../unxmacxi.pro/misc/win_ulffiles
>>>
>>> msi language path will be ignored for non Windows builds!
>>> Calling epm
>>> Stripping files
>>> Unzip ARCHIVE files
>>> Languages:
>>>       en-US
>>> ########################################################
>>> ... checking required files ...
>>> ...... searching zip ...
>>>       Found: /usr/bin/zip
>>> ... analyzing ../util/openoffice.lst ...
>>> rmdir:
>>> /Users/server3/Documents/build59/main/instsetoo_native/unxmacxi.pro/OpenOffice/archive/logging/:
>>>
>>> Directory not empty
>>> ... reading include pathes ...
>>> ... analyzing script:
>>> /Users/server3/Documents/build59/main/solver/340/unxmacxi.pro/bin/setup_osl.ins
>>>
>>> ...
>>> ... analyzing directories ...
>>> ... analyzing files ...
>>> ... analyzing scpactions ...
>>> ... analyzing shortcuts ...
>>> ... analyzing unix links ...
>>> ... analyzing profile ...
>>> ... analyzing profileitems ...
>>> ... analyzing modules ...
>>> ------------------------------------
>>> ... languages en-US ...
>>> ... analyzing files ...
>>> preparing 0 extension blobs for language en-US:
>>> preparing 0 bundled extensions for language en-US:
>>>
>>> ERROR: The following files could not be found:
>>> ERROR: File not found: Arimo-Bold.ttf
>>> ERROR: File not found: Arimo-BoldItalic.ttf
>>> ERROR: File not found: Arimo-Italic.ttf
>>> ERROR: File not found: Arimo-Regular.ttf
>>> ERROR: File not found: Cousine-Bold.ttf
>>> ERROR: File not found: Cousine-BoldItalic.ttf
>>> ERROR: File not found: Cousine-Italic.ttf
>>> ERROR: File not found: Cousine-Regular.ttf
>>> ERROR: File not found: GenBasB.ttf
>>> ERROR: File not found: GenBasBI.ttf
>>> ERROR: File not found: GenBasI.ttf
>>> ERROR: File not found: GenBasR.ttf
>>> ERROR: File not found: GenBkBasB.ttf
>>> ERROR: File not found: GenBkBasBI.ttf
>>> ERROR: File not found: GenBkBasI.ttf
>>> ERROR: File not found: GenBkBasR.ttf
>>> ERROR: File not found: SymbolNeu.ttf
>>> ERROR: File not found: Tinos-Bold.ttf
>>> ERROR: File not found: Tinos-BoldItalic.ttf
>>> ERROR: File not found: Tinos-Italic.ttf
>>> ERROR: File not found: Tinos-Regular.ttf
>>> ... cleaning the output tree ...
>>> ... removing directory /tmp/ooopackaging/i_785841338544113 ...
>>>
>>
>> These fonts come from the gentiumbasic-fonts-1.10.zip archive.
>>
>> According to this line main/ooo.lst
>>
>> WITH_CATB_FONTS:35efabc239af896dfb79be7ebdd6e6b9-gentiumbasic-fonts-1.10.zip
>>
>>
>> this archive is only used when the WITH_CATB_FONTS environment
>> variable is set (through some option to configure).
>>
>> Is it possible that the value of WITH_CATB_FONTS has changed between
>> running configure and running build in instsetoo_native?
> I didn't use WITH_CATB_FONTS at all

That is strange.  main/scp2/source/ooo/file_font_ooo.scp is the scp file 
that controls whether the fonts mentioned above are included or 
excluded.  All these fonts are guarded with the WITH_CATB_FONTS flag.
When it is not set (at the time when scp2 was built) then the fonts 
should not be included and the above error should not appear.

When WITH_CATB_FONTS is not set then I have no explanation for the error.

-Andre

Mime
View raw message