incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: Java
Date Wed, 20 Jun 2012 02:07:58 GMT
Hi Andrew, Maya

Maya is not subscribed to the list, so she missed your answer; I'm Ccing
here now.

On Tue, Jun 19, 2012 at 06:57:34PM -0400, Andrew Douglas Pitonyak wrote:
> 
> On 06/19/2012 12:29 PM, Maya Cain wrote:
> >I had an older copy of OpenOffice which ran very well but then I found
> >there was a newer version and so I updated and now my database will not
> >work.  I get a message saying that the Java environment has changed.  The
> >text function and the spreadsheets both appear to be working.  Can you tell
> >me, please, what I need to do to fix this as I have a very large database
> >which, at the moment, I cannot edit.
> >
> >Thank you for any help.
> >
> >Maya Cain
> >
> Not entirely sure, but try this:
> 
> Use Tools > Options > OpenOffice.org > Java
> 
> The top check box should be set to use Java.
> 
> It may take a bit, but a list of available Java implementations
> should be shown. I may be mistaken, but, I think that OOo will work
> with a java version 1.6.x but not 1.7.x, so, select a version that
> begins with 1.6.

I theory (and practice) Java 7 works, though there are some users
reporting it does not work for them:

https://issues.apache.org/ooo/show_bug.cgi?id=119525
https://issues.apache.org/ooo/show_bug.cgi?id=119993

I couldn't reproduce any of them, Java 7u5 works fine on Windows XP 32
bits, and Windows 7 64 bits; OpenJDK 1.7.0_03-icedtea works fine on
Fedora 17.


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message