incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nelson Marques <nmo.marq...@gmail.com>
Subject Building AAO from source...
Date Sun, 20 May 2012 17:11:56 GMT
Hi,

I've setup a small environment to test some building of AAO, but I'm
somehow stuck and I'm not really sure why I'm having a weird behavior.

I'm not really sure what is causing this, but the path translation is
all twisted, ex:
/home/nmarques/aoo/aoo-3.4.0/main/solenv/unxlngxpro/incnc/mywlrld.mk

I assume this would be something like:
/home/nmarques/aoo/aoo-3.4.0/main/solenv/unxlngxpro/inc/myworld.mk

Which means something is very wrong... full output bellow... My
configure options are:

./configure --prefix=/opt/my-aoo  \
            --with-system-libs    \
            --with-mingwin=/usr/bin/i686-pc-mingw32-c++  \
            --with-vendor="SOME-TEST"                     \
            --enable-gstreamer                          \
            --enable-cairo                              \
            --enable-opengl                             \
            --enable-dbus                               \
            --enable-category-b                         \
            --enable-bundled-dictionaries


[nmarques@odin instsetoo_native]# build --all
build -- version: 275224


=============
Building module solenv
=============

Entering /home/nmarques/aoo/aoo-3.4.0/main/solenv

dmake:  /home/nmarques/aoo/aoo-3.4.0/main/solenv/inc/settings.mk:
line 618:  Error: -- Include file
/home/nmarques/aoo/aoo-3.4.0/main/solenv/unxlngxpro/incnc/mywlrld.mk,
not found
---* SETTINGS.MK *---

1 module(s):
	solenv
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making
/home/nmarques/aoo/aoo-3.4.0/main/solenv

When you have fixed the errors in that module you can resume the build
by running:

	build --all:solenv




-- 
Nelson Marques
// I've stopped trying to understand sandwiches with a third piece of
bread in the middle...

Mime
View raw message